Are there any guide line to run sample-broker?

classic Classic list List threaded Threaded
27 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Re: Are there any guide line to run sample-broker?

grampajohn
Administrator
Hello, Tony -
tony2010 wrote
Now, I will present problem in my desktop. My desktop is run in my school. Although I turn off all security of school such as firewall, virus software, brother authentication, servers and brokers do not communicate together. In particular, the some steps are implemented by me as follows.

- I sucessfully run servers and brokers
- Bootstrap.txt is generated in bootstrap mode.
- I run sim mode with config/bootstrap.txt. But broker sample received zero in cash balance, energy balance and subs. You can see my result with the following link:
I looked at the log you posted, and the problem is that the server is rejecting the tariffs from the sample broker. The entries in the server log look like
154683 WARN  common.Rate: maxValue 0.0 out of range
154683 WARN  common.TariffSpecification: invalid rate
154683 WARN  tariffmarket.TariffMarketService: invalid spec 200000388
In the broker log, you can see that your tariffs are being rejected because the tariff-status message comes back with "invalidTariff". Here's what it looks like:
133453 INFO  core.BrokerMessageReceiver: onMessage(String) - received message:
<tariff-status id="1525" tariffId="200000388" updateId="200000388" status="invalidTariff">
  <broker>Sample</broker>
</tariff-status>
In the code, the "maxValue out of range" message is generated only when the rate is not fixed, and the maxValue is less than the minValue. But your rates are fixed - I checked - so this should not be happening.

So I thought perhaps there was a problem with the web version that's posted on the download page. To check, I pulled out my laptop, downloaded fresh copies of the 0.6.3-SNAPSHOT versions of both the server and sample broker, and cleared out the org/powertac tree in my local maven repository at ~/.m2/repository/org/powertac. I ran a boot session, then both a cli and web sim. All of them work fine.

According to the logs you posted, this is not a firewall problem. It looks like out-of-date code. There are two things you can try: (1) run the sample broker as
mvn clean compile exec:exec
If that does not work, then (2) pull down fresh downloads for both the server and broker, clear out your local maven repository, and try again. Make sure you compile the broker before you try to run it.

I hope this helps.

John
Reply | Threaded
Open this post in threaded view
|

Re: Are there any guide line to run sample-broker?

tony2010
Hi John,

Thank you for your guidance. I follow your guidance to fix it but the error is not fixed. I present what I did as follows:

(1) I run the sample broker as mvn clean compile exec:exec. But cash balane, energy balance and subs in the sample broker is still zero.

(2) I deleted all old packages and go to web to down new packages with version 0.6.3 and run it again but cash balane, energy balance and subs in the sample broker is still zero.

In my opinion, the error happens because my desk is joined domain of University. My desk was provided by Uni to study in University. Thus, when the simulation runs, the simulation communicates with your servers and it is protected by domain of University. so, the result is that server can not communicate with sample brokers. Please give me your opinion in my case. If you agree with me, I will not spent a lot of time on fixing it next time. If you do not agree with me, I will continue to fix it.

I am looking forward to hearing from you. Thank you in advance!

Best regards,
Le

Reply | Threaded
Open this post in threaded view
|

Re: Are there any guide line to run sample-broker?

Tony
Hi John,

This morning, I required the staff in my school to modify my desktop so that my desktop do not joined domain of school. But the error still happens. In particular, cash balance, energy balance, subscribe in sample broker is zero.

As your suggestion, I should run mvn clean compile exec:exec in sample broker, but there are some errors as follows:

C:\Users\Administrator\Desktop\THu\sample-broker1>mvn clean compile exec:exec
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building sample-broker 0.6.3-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[WARNING] The artifact org.apache.commons:commons-io:jar:1.3.2 has been relocate
d to commons-io:commons-io:jar:1.3.2
[INFO]
[INFO] --- maven-clean-plugin:2.4.1:clean (default-clean) @ sample-broker ---
[INFO] Deleting C:\Users\Administrator\Desktop\THu\sample-broker1\target
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.342s
[INFO] Finished at: Fri Dec 07 11:11:15 EST 2012
[INFO] Final Memory: 7M/105M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-clean-plugin:2.4.1
:clean (default-clean) on project sample-broker: Failed to clean project: Failed
 to delete C:\Users\Administrator\Desktop\THu\sample-broker1\target\classes\log4
j.properties -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit
ch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please rea
d the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionE
xception
'cmd' is not recognized as an internal or external command,
operable program or batch file.
C:\Users\Administrator\Desktop\THu\sample-broker1>

Furthermore, I run mvn clean install in sample broker, then I run mvn compile exec:exec -Dexec.args="--config broker.properties" command. The result is that cash balance, energy balance, subscribe in sample broker is zero. Other way is that I downloaded all packages from web and run them again but the result is the sample.

To be honest, I spent a lot of time on fixing it but I can not fix it. I would like to receive your help.

Thank you in advance!

Cheers,
Tony
Reply | Threaded
Open this post in threaded view
|

Re: Are there any guide line to run sample-broker?

grampajohn
Administrator
Tony wrote
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-clean-plugin:2.4.1
:clean (default-clean) on project sample-broker: Failed to clean project: Failed
 to delete C:\Users\Administrator\Desktop\THu\sample-broker1\target\classes\log4
j.properties -> [Help 1]
It appears that you do not have permission to delete files from the location where you have installed the sample-broker code. Why do you have it in an Administrator directory, instead of in your own user directory?

It's possible that this has been your problem all along.

Cheers -

John
Reply | Threaded
Open this post in threaded view
|

Re: Are there any guide line to run sample-broker?

Tony
Hi John,

Thanks much for giving me necessary information to fix my error. I feel very happy when my error is fixed. I present as follows:

1. Run server by using Visualier directory I do not run server by using power-serve-0.6.3 shatshot. I use mvn jetty:run command.
2. Run mvn compile exec:exec -Dexec.args="--config broker.properties" command in sample broker.

Now, Server and sample broker work very well in my desktop. Today it is too lucky for me.

Thanks much for all your hard and patience.

Best regards,
Tony
Reply | Threaded
Open this post in threaded view
|

Re: Are there any guide line to run sample-broker?

mnayeem
Could you help me, please?

Default broker was loaded with a new game and waiting for sample broker. I put the command in Sample broker- session 1 started but SIM mode not initiated with Sample broker rather it's waiting waiting -

Reply | Threaded
Open this post in threaded view
|

Re: Are there any guide line to run sample-broker?

grampajohn
Administrator

I posted a reply on nabble. This is very odd. I assume by "default broker" you mean the simulation server -- that's what runs from server-distribution.

John

On 5/9/21 2:32 AM, mnayeem [via Power TAC Developers] wrote:
Could you help me, please?

Default broker was loaded with a new game and waiting for sample broker. I put the command in Sample broker- session 1 started but SIM mode not initiated with Sample broker rather it's waiting waiting -




If you reply to this email, your message will be added to the discussion below:
http://power-tac-developers.975333.n3.nabble.com/Are-there-any-guide-line-to-run-sample-broker-tp4025215p4027089.html
To start a new topic under Power TAC Developers, email [hidden email]
To unsubscribe from Power TAC Developers, click here.
NAML
12