Visualizer issue for PowerTAC tariff Analysis

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Visualizer issue for PowerTAC tariff Analysis

lmbhat
The PowerTAC game is working perfectly fine. But when I click anything in Tariff Market tab in visualizer I get an error. Please find the screenshot of the error attached to this post. The error is only for Tariff Analysis. Other KPI are working fine.Power TAC Tariff Market Visualization Error
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

erikkemperman
Hi Imbhat,

Thanks for reporting this issue. It looks like this is the old visualizer, correct? We don't really maintain that anymore, but keep it around because it has some plots that the new version (-P web2) does not yet have.

I'll take a look to see if it's something that can be easily remedied, as soon as I have some time.

Gr
Erik
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

lmbhat
Yes I was using the old visualizer.
Tariff analysis seems to be working with the new visualizer. Thanks for letting me know.
However,I don't see a weather graphs in the new visualizer. Kindly help me in this issue?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

erikkemperman
Yes, like I said, the new visualizer doesn't have all the graphs yet, unfortunately. I'm working on it but other things keep coming up. I hope you will understand, sorry for the inconvenience!

Gr
Erik
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

lmbhat
I understand.Thanks you so much for your help!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

erikkemperman
Hi Imbhat,

I've looked into this and found the superficial cause. However I will need input from John to determine the appropriate remedy.

To track this issue I have created:
https://github.com/powertac/powertac-server/issues/923

Thanks for your patience,
Erik
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

erikkemperman
Hi Imbhat,

The fix for the problem with the old visualizer has been merged and deployed as version 1.4.2-SNAPSHOT.

Thanks again for bringing it to our attention!

Gr
Erik
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

grampajohn
Administrator
erikkemperman wrote
The fix for the problem with the old visualizer has been merged and deployed as version 1.4.2-SNAPSHOT.

Thanks again for bringing it to our attention!
Remember, if you want to run this version you may need to download the 1.4.2-SNAPSHOT version of server-distribution. The most recent version is always available at the server-distribution page on github.

Cheers -

John
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

lmbhat
Hello. I am currently using the new visualizer. As the old visualizer has more functionalities I would like to use the old one. As told by you in the previous post, I am going the snapshot server directory and entering the command mvn -P web to use the old visualizer. However, I am getting the following error.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

erikkemperman
Hi Imbhat,

The problem is actually printed in the error message: Address already in use. This means another process (possibly another visualizer?) has already bound to port 8080, so the server you are starting is unable to bind to the same port.

Govert tells me that on Windows, maven apparenly prefers to start processes as "daemon", meaning they could continue running after it appears they're gone.

Please check your process list to see what is currently listening on port 8080 and kill it. Alternatively, you can tell the visualizer to listen on a different port, e.g. "mvn -Pweb -Djetty.port=7070".

Hope this helps!

gr,
Erik
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

lmbhat
Your solution worked perfectly well.

Could you tell me what does the last graph signify in tariff analysis,Wholesale market,Weather etc. Is it power demand?







Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Visualizer issue for PowerTAC tariff Analysis

erikkemperman
Hi Imbhat,

Sorry, but I'm not entirely sure what you mean -- the vertical axes are pretty clearly labeled it seems to me?

If you mean the narrow panel below each of the graphs, it is a "navigator" whose sliders allow you to set the scope of the x-axes.

Does this help?
Loading...