Visualizer/proxy issue

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Visualizer/proxy issue

adis
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Visualizer/proxy issue

ddauer
However, after running the server, and then the visualizer plugin, nothing happens.

Uhm wait, so you're not including the plugin as a plugin within the server but running it separately?

Cheers,
David

Reply | Threaded
Open this post in threaded view
|

Re: Visualizer/proxy issue

adis
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Visualizer/proxy issue

ddauer
No - that couldn't work. I've looked at the code and committed a working version in which init() is called. I've also added the plugin to powertac-server. If you update both projects you'll see your log messages.

The visualizer is, at least for now, only part of the server. That's why it can't run separately, but it should be built in a way that it could later on. VisualizationProxy is a component internal to the server and will not be available when running the visualizer as a separate instance. In the latter case you'll have to receive all messages though a JMS channel, but that is not important for now.

All you need to do now is just run powertac-server. There is no need to run both projects.

Cheers,
David


Reply | Threaded
Open this post in threaded view
|

Re: Visualizer/proxy issue

adis
CONTENTS DELETED
The author has deleted this message.