error creating bean

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

error creating bean

ibariens
Dear mr Collins and mr Ketter,

I still get an error trying to run the powertac server and demo agent.
I use smartgit and use the options 'merge changes from tracked branch' on and 'throw away local
changes' off when switching to the release 0.2 branch.

the first errors given during compiling the demo-agent are (i think the one in bold is the most important
since the same message is given during the compiling process of the server):

2011-05-23 20:57:38,017 [main] WARN net.sf.ehcache.config.ConfigurationFactory - No
configuration found. Configuring ehcache from ehcache-failsafe.xml found in the classpath:
jar:file:/Users/dart_art/.ivy2/cache/net.sf.ehcache/ehcache-core/jars/ehcache-core-1.7.1.jar!
/ehcache-failsafe.xml

2011-05-23 20:57:38,511 [main] WARN net.sf.ehcache.hibernate.EhCacheProvider - Could not find a
specific ehcache configuration for cache named [org.powertac.common.Competition]; using defaults.

2011-05-23 20:57:38,864 [main] WARN net.sf.ehcache.hibernate.EhCacheProvider - Could not find a
specific ehcache configuration for cache named [org.powertac.common.Role]; using defaults.

2011-05-23 20:57:38,973 [main] WARN net.sf.ehcache.hibernate.EhCacheProvider - Could not find a
specific ehcache configuration for cache named [org.powertac.common.Broker]; using defaults.

2011-05-23 20:57:39,073 [main] WARN org.hibernate.impl.SessionFactoryObjectFactory -
InitialContext did not implement EventContext

2011-05-23 20:57:39,363 [main] WARN net.sf.ehcache.hibernate.EhCacheProvider - Could not find a
specific ehcache configuration for cache named [org.hibernate.cache.UpdateTimestampsCache];
using defaults.

2011-05-23 20:57:39,366 [main] WARN net.sf.ehcache.hibernate.EhCacheProvider - Could not find a
specific ehcache configuration for cache named [org.hibernate.cache.StandardQueryCache]; using
defaults.

2011-05-23 20:57:40,062 [main] INFO
org.codehaus.groovy.grails.scaffolding.DefaultGrailsTemplateGenerator - Scaffolding template
generator set to use resource loader
org.codehaus.groovy.grails.commons.spring.GrailsWebApplicationContext@4ffac352: startup date [Mon

May 23 20:57:36 CEST 2011]; parent: Root WebApplicationContext
2011-05-23 20:57:40,236 [main] ERROR org.codehaus.groovy.grails.web.context.GrailsContextLoader -
Error executing bootstraps: Error creating bean with name 'standardJmsTemplate': Cannot resolve
reference to bean 'jmsConnectionFactory' while setting bean property 'connectionFactory'; nested
exception is org.springframework.beans.factory.BeanCreationException:


I use OSX Snow Leopard, Grails 1.3.7 and Groovy 1.8.0.

Thank you for your help, I hope i provided all relevant information.

Yours sincerely,

Bart Ariens
Reply | Threaded
Open this post in threaded view
|

Re: error creating bean

ddauer
Hi Bart,

it seems the jms plugin is not loaded. Let's try some troubleshooting:

- Are you seeing any "missing plugin" errors at the very beginning when running the demo agent? 
- Does the same error occur with powertac-server?
- Have you tried "grails clean; grails run-app"?
- Could you please post the complete log output at http://chopapp.com/ or some similar page and send the link?

Thanks,
David
Reply | Threaded
Open this post in threaded view
|

Re: error creating bean

ibariens
This post was updated on .
Dear David,

Thank you for the fast reply.

The compile process of the server gives: http://www.chopapp.com/#2qv3ztki
The compile process of the demo agent gives: http://www.chopapp.com/#ysgsztys

complete log server: is 7mb big, so chopapp.com<http://chopapp.com> isn't working
complete log demo agent: http://chopapp.com/#fnm4nnvn

I don't see any 'missing plugins' i guess.

i'm quite new in this process, so i hope i provided all necessary information.

Thanks,

Bart

Reply | Threaded
Open this post in threaded view
|

Re: error creating bean

ddauer
Hi Bart,

maybe SmartGit didn't work the way it was supposed to when switching branches. I'm not getting this error on a clean checkout of powertac-demo-agent-grails and powertac-common. Could you try that please?

Cheers,

David
Reply | Threaded
Open this post in threaded view
|

Re: error creating bean

ibariens
thanks for the reply, unfortunately still no success.


i deleted the powertac-demo-agent-grails directory and the powertac-common directory
then in the terminal:

git clone https://github.com/powertac-plugins/powertac-common.git
git clone https://github.com/powertac/powertac-demo-agent-grails.git
then: git checkout release-0.2 in both directories

then in the powertac-demo-agent-grails directory i ran: grails run-app

unfortunately still getting errors: http://chopapp.com/#7xy7pu4m

am i doing something wrong, maybe because i'm using osx?

cheers,
bart

Reply | Threaded
Open this post in threaded view
|

Re: error creating bean

ddauer
Well, last idea: try removing ~/.grails and do the same again. It's working fine here on osx as well.

I'm hoping someone else might have another idea...

Cheers,
David
Reply | Threaded
Open this post in threaded view
|

Re: error creating bean

ibariens
thanks, i will try it in the morning. i'll keep you posted

cheers, bart
Reply | Threaded
Open this post in threaded view
|

Re: error creating bean

ibariens
In reply to this post by ddauer
Strange, when removing and reinstalling the grails enviroment, I got the powertac-demo-agent working for 1 time only. But the second time it failed, and now even after reinstalling it still fails... I will keep playing around and give you an update if I got it working.

thanks for your help,

bart